using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]";
string substitution = @"$1['$2']";
string input = @"$row[number]; $row[user];
$row['number']; $row['user'];";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}