const regex = /(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<variable>[$][a-zA-Z_\\x80-\\xff][a-zA-Z0-9_\\x80-\\xff]*)[[](?<index>[^\']+?)[\\]]', 'gm')
const str = `\$row[number]; \$row[user];
\$row['number']; \$row['user'];`;
const subst = `$1['$2']`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);