$re = '/(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^\']+?)[\]]/m';
$str = '$row[number]; $row[user];
$row[\'number\']; $row[\'user\'];';
$subst = "$1['$2']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;