re = /(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]/m
str = '$row[number]; $row[user];
$row[\'number\']; $row[\'user\'];'
subst = '$1[\'$2\']'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result