use strict;
my $str = '$row[number]; $row[user];
$row[\'number\']; $row[\'user\'];';
my $regex = qr/(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]/mp;
my $subst = '$1[\'$2\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";