package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<variable>[$][a-zA-Z_\x80-\xff][a-zA-Z0-9_\x80-\xff]*)[[](?<index>[^']+?)[\]]`)
var str = `$row[number]; $row[user];
$row['number']; $row['user'];`
var substitution = "$1['$2']"
fmt.Println(re.ReplaceAllString(str, substitution))
}