# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\<code\>(.*?)\<\\/code\>/\$\g<1>\$/gm;t' <<< "<tr><td><code>\csc</code></td>
<td><img class=\"tex\" alt=\"\csc\" src=\"http:sharelatex.com\"></td></tr>"