import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<code\\>(.*?)\\<\\/code\\>";
final String string = "<tr><td><code>\\csc</code></td>\n"
+ "<td><img class=\"tex\" alt=\"\\csc\" src=\"http:sharelatex.com\"></td></tr>";
final String subst = "\\$\\g<1>\\$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}