$re = '/\<code\>(.*?)\<\/code\>/m';
$str = '<tr><td><code>\\csc</code></td>
<td><img class="tex" alt="\\csc" src="http:sharelatex.com"></td></tr>';
$subst = "\$\g<1>\$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;