import Foundation
let pattern = #"\<code\>(.*?)\<\/code\>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<tr><td><code>\csc</code></td>
<td><img class="tex" alt="\csc" src="http:sharelatex.com"></td></tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\$\g<1>\$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)