const regex = new RegExp('\\<code\\>(.*?)\\<\\/code\\>', 'gm')
const str = `<tr><td><code>\\csc</code></td>
<td><img class="tex" alt="\\csc" src="http:sharelatex.com"></td></tr>`;
const subst = `\$\g<1>\$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);