package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\<code\>(.*?)\<\/code\>`)
var str = `<tr><td><code>\csc</code></td>
<td><img class="tex" alt="\csc" src="http:sharelatex.com"></td></tr>`
var substitution = "\$\g<1>\$"
fmt.Println(re.ReplaceAllString(str, substitution))
}