use strict;
my $str = '<tr><td><code>\\csc</code></td>
<td><img class="tex" alt="\\csc" src="http:sharelatex.com"></td></tr>';
my $regex = qr/\<code\>(.*?)\<\/code\>/mp;
my $subst = '\\$\\g<1>\\$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";