#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\<code\>(.*?)\<\/code\>"
Local $sString = "<tr><td><code>\csc</code></td>" & @CRLF & _
"<td><img class="tex" alt="\csc" src="http:sharelatex.com"></td></tr>"
Local $sSubst = "\$\g<1>\$"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)