import re
regex = re.compile(r"\<code\>(.*?)\<\/code\>", flags=re.MULTILINE)
test_str = ("<tr><td><code>\\csc</code></td>\n"
"<td><img class=\"tex\" alt=\"\\csc\" src=\"http:sharelatex.com\"></td></tr>")
subst = "\\$\\g<1>\\$"
result = regex.sub(subst, test_str)
if result:
print(result)