using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<code\>(.*?)\<\/code\>";
string substitution = @"\$\g<1>\$";
string input = @"<tr><td><code>\csc</code></td>
<td><img class=""tex"" alt=""\csc"" src=""http:sharelatex.com""></td></tr>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}