using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\(\) => import\()'@/([^']*)'\)";
string substitution = @"$1/* webpackChunkName: ""$2"" */ '@/$2')";
string input = @"() => import('@/components/something/Something')
with
() => import(/* webpackChunkName: ""components--something--Something"" */ '@/components/something/Something')";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}