use strict;
my $str = '() => import(\'@/components/something/Something\')
with
() => import(/* webpackChunkName: "components--something--Something" */ \'@/components/something/Something\')';
my $regex = qr~(\(\) => import\()'@/([^']*)'\)~mp;
my $subst = '$1/* webpackChunkName: "$2" */ \'@/$2\')';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";