// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\(\) => import\()'@/([^']*)'\)").unwrap();
let string = "() => import('@/components/something/Something')
with
() => import(/* webpackChunkName: \"components--something--Something\" */ '@/components/something/Something')";
let substitution = "$1/* webpackChunkName: \"$2\" */ '@/$2')";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}