const regex = new RegExp('(\\(\\) => import\\()\\'@/([^\\']*)\\'\\)', 'gm')
const str = `() => import('@/components/something/Something')
with
() => import(/* webpackChunkName: "components--something--Something" */ '@/components/something/Something')`;
const subst = `$1/* webpackChunkName: "$2" */ '@/$2')`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);