re = /(\(\) => import\()'@\/([^']*)'\)/m
str = '() => import(\'@/components/something/Something\')
with
() => import(/* webpackChunkName: "components--something--Something" */ \'@/components/something/Something\')'
subst = '$1/* webpackChunkName: "$2" */ \'@/$2\')'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result