# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ebrd\.comDiskUtilization-([A-Z])\([^)]+\) --/ /gm;t' <<< "ldn2spc2.ebrd.comDiskUtilization-D(Disk) --> Disk Utilization 100 > 95
%(threshold)"