import re
regex = re.compile(r"ebrd\.comDiskUtilization-([A-Z])\([^)]+\) --", flags=re.MULTILINE)
test_str = ("ldn2spc2.ebrd.comDiskUtilization-D(Disk) --> Disk Utilization 100 > 95\n"
"%(threshold)")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)