const regex = new RegExp('ebrd\\.comDiskUtilization-([A-Z])\\([^)]+\\) --', 'gm')
const str = `ldn2spc2.ebrd.comDiskUtilization-D(Disk) --> Disk Utilization 100 > 95
%(threshold)`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);