import Foundation
let pattern = #"ebrd\.comDiskUtilization-([A-Z])\([^)]+\) --"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ldn2spc2.ebrd.comDiskUtilization-D(Disk) --> Disk Utilization 100 > 95
%(threshold)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)