re = /ebrd\.comDiskUtilization-([A-Z])\([^)]+\) --/m
str = 'ldn2spc2.ebrd.comDiskUtilization-D(Disk) --> Disk Utilization 100 > 95
%(threshold)'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result