use strict;
my $str = 'ldn2spc2.ebrd.comDiskUtilization-D(Disk) --> Disk Utilization 100 > 95
%(threshold)';
my $regex = qr/ebrd\.comDiskUtilization-([A-Z])\([^)]+\) --/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";