# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\s|,)[a-z]/\U\0/g;t' <<< "grande,la,tengo,más,la,quisiera"