use strict;
my $str = 'grande,la,tengo,más,la,quisiera';
my $regex = qr/(^|\s|,)[a-z]/p;
my $subst = '\\U\\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";