re = /(^|\s|,)[a-z]/
str = 'grande,la,tengo,más,la,quisiera'
subst = '\\U\\0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result