import re
regex = re.compile(r"(^|\s|,)[a-z]")
test_str = "grande,la,tengo,más,la,quisiera"
subst = "\\U\\0"
result = regex.sub(subst, test_str)
if result:
print(result)