const regex = /(^|\s|,)[a-z]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\s|,)[a-z]', 'g')
const str = `grande,la,tengo,más,la,quisiera`;
const subst = `\U\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);