$re = '/(^|\s|,)[a-z]/';
$str = 'grande,la,tengo,más,la,quisiera';
$subst = "\U\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;