#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|\s|,)[a-z]"
Local $sString = "grande,la,tengo,más,la,quisiera"
Local $sSubst = "\U\0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)