const regex = /[\?]?([\w]+)=([\w-]+)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\?]?([\\w]+)=([\\w-]+)', 'mg')
const str = `/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing
/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes`;
const subst = `$1=$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);