import Foundation
let pattern = #"[\?]?([\w]+)=([\w-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing
/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1=$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)