import re
regex = re.compile(r"[\?]?([\w]+)=([\w-]+)", flags=re.MULTILINE)
test_str = ("/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing\n"
"/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes")
subst = "$1=$2"
result = regex.sub(subst, test_str)
if result:
print(result)