$re = '/[\?]?([\w]+)=([\w-]+)/m';
$str = '/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing
/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes';
$subst = "$1=$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;