use strict;
my $str = '/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing
/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes';
my $regex = qr/[\?]?([\w]+)=([\w-]+)/mp;
my $subst = '$1=$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";