// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\?]?([\w]+)=([\w-]+)").unwrap();
let string = "/warehouse/home.php?mode=shipping&orderid=16158437&barcodeid=16158437001&action=complete&referrer=packing
/warehouse/home.php?mode=inventory&bin=10-W-1&keep_https=yes";
let substitution = "$1=$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}