#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\{([^#|T|(])"
Local $sString = "{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]" & @CRLF & _
"{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]" & @CRLF & _
"{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}" & @CRLF & _
""
Local $sSubst = "{'{'}$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)