package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{([^#|T|(])`)
var str = `{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]
{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]
{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}
`
var substitution = "{'{'}$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}