$re = '/\{([^#|T|(])/m';
$str = '{#endpoints[\'default\']}/{#group[0]}/{\'1\',\'2\',\'3\'}.^[true]
{#endpoints[\'default\']}/{#group[0]}/{(\'1\'),\'2\',\'3\'}.^[true]
{id: {#request.paths[2]}, firstname: {#properties[\'firstname_123\']}, name: {#properties[\'name_123\']}, age: 0}
';
$subst = "{'{'}$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;