// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\{([^#|T|(])").unwrap();
let string = "{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]
{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]
{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}
";
let substitution = "{'{'}$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}