import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{([^#|T|(])";
final String string = "{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]\n"
+ "{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]\n"
+ "{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}\n";
final String subst = "{'{'}$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}