import Foundation
let pattern = ##"\{([^#|T|(])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]
{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]
{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{'{'}$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)