use strict;
my $str = '{#endpoints[\'default\']}/{#group[0]}/{\'1\',\'2\',\'3\'}.^[true]
{#endpoints[\'default\']}/{#group[0]}/{(\'1\'),\'2\',\'3\'}.^[true]
{id: {#request.paths[2]}, firstname: {#properties[\'firstname_123\']}, name: {#properties[\'name_123\']}, age: 0}
';
my $regex = qr/\{([^#|T|(])/mp;
my $subst = '{\'{\'}$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";