import re
regex = re.compile(r"\{([^#|T|(])", flags=re.MULTILINE)
test_str = ("{#endpoints['default']}/{#group[0]}/{'1','2','3'}.^[true]\n"
"{#endpoints['default']}/{#group[0]}/{('1'),'2','3'}.^[true]\n"
"{id: {#request.paths[2]}, firstname: {#properties['firstname_123']}, name: {#properties['name_123']}, age: 0}\n")
subst = "{'{'}$1"
result = regex.sub(subst, test_str)
if result:
print(result)