package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*)@((\w*\|\w*#{0,1})*)`)
var str = `foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}