use strict;
my $str = 'foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN';
my $regex = qr/(\w*)@((\w*\|\w*#{0,1})*)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";